[Astuces] Excel

1 – Figer/Geler une colonne

Utiliser le signe « $ » pour « figer » ou « geler » une colonne ou une ligne dans une formule. Quand la formule sera recopiée, les parties gelées ne changeront pas.

A1 : Ni la colonne, ni la ligne sont gelées.

$A1 : La colonne est gelée mais pas la ligne.

A$1 : La ligne est gelée mais pas la colonne.

$A$1 : La ligne et la colonne sont gelées.

2 – Répéter une action


Appuyer sur la touche F4

3 – Couleur différente une ligne sur 2

Sélectionner la zone puis menu mise en forme conditionnelle

Sélectionner ‘La formule est’

=MOD(LIGNE();2) 

4 – Chiffre qui revient le plus souvent

=MODE(B1:B5)

Comment faire disparaître le # N/A

Avec MODE vous avez peut être #N/A,pour l’enlever utiliser cette fonction:

=si(estna(maformule);"";maformule)
Exemple : =si(ESTNA(MODE(B785:F785));"";MODE(B785:F785))

5 – Colorier une cellule si une cellule = une autre cellule

Sélectionner les cellules que vous voulez colorier.

Cliquez sur « Mise en forme conditionnelle »
Puis « Nouvelle règle »
Sélectionner « Appliquer une mise….cellules qui contiennent »

Choisissez « Valeur de la cellule »

Mettre la colonne qui doit correspondre en rajoutant le chiffre 1
Exemple: =$B1


Dans Format choisissez votre mise en forme.Pour finir si vous ne voulez pas que les cellules vides soient coloriés
Sélectionner les colonnes
Appliquer une mise en forme est égale a « 0« Et dans Format > Remplissage,choisir Aucune couleur.

6 – Soustraction Positive

=ABS(A1-B1) 
Renvoie la valeur absolue de la soustraction A1-B1, donc « supprime » le signe –

7 – Supprimer une liaison

Un message indique « Le classeur que vous avez ouvert comporte des liaisons avec un autre classeur. Voulez-vous mettre à jour ce classeur OUI/NON »

Pour l’enlever sous excel 2010,en Haut,Onglet « Données »
Puis dans Groupe « Connexions » cliquez sur « Modifier les liens » et le Supprimer.

8. Supprimer les cellules vides

Sélectionner la première colonne de votre tableau.
Affichez la boîte de dialogue « Atteindre » touche “F5”.
Cliquez sur le bouton « Cellules…« .
Sélectionner l’option « Cellules vides« .

9 – Trouver une valeur dans une plage

=SI(NB.SI(K2:O2;B2)0;1;0)


10- Afficher ou masquer toutes les valeurs zéro dans une feuille de calcul

  1. Cliquez sur le bouton Microsoft Office , cliquez sur Options Excel, puis sur la catégorie Options avancées.
  1. Sous Afficher les options pour cette feuille de calcul, sélectionnez une feuille de calcul et effectuez l’une des actions suivantes :
    • Pour afficher les valeurs zéro (0) dans les cellules, activez la case à cocher Afficher un zéro dans les cellules qui ont une valeur nulle.
    • Pour afficher les valeurs zéro sous la forme de cellules vides, désactivez la case à cocher Afficher un zéro dans les cellules qui ont une valeur nulle.

11 – Supprimer les lignes vides a la fin

Installer ASAP Utilities
Ouvrir la feuille excel et supprimer les lignes non utilisés en selectionant la dernière puis faire :
CTRL + MAJ + BAS
Puis clique-droit,SUPPRIMER.
Ensuite en haut dans ASAP Utilities allez dans Colonnes et Lignes
Cliquez tout en bas sur  » Supprimer les vides inutilisés de fin de lignes »

12 – Ce Classeur comporte une liaison

Pour enlever ce message,il faut rechercher la liaison.
Rechercher avec (Ctrl+F) le caractère « [ » dans tout le classeur.
Supprimer la liaison.

13 – Remplacer #DIV/0! par une case vide 

=SI(ESTERREUR(Formule); » »;(Formule))

Exemple:
=SI(ESTERREUR(B16/(C16+D16)); » »;(B16/(C16+D16)))

14 – Transposer une Plage (Horizontal/Vertical)

Sélectionner la nouvelle plage
Taper =TRANSPOSE(B6:B12)
Valider avec CTRL+MAJ+ENTREE

 15 – Lien Hypertexte

F2 contient le numéro de suivi.

=LIEN_HYPERTEXTE(« http://www.part.csuivi.courrier.laposte.fr/suivi/index?id= »&F2)

=LIEN_HYPERTEXTE(« http://www.lesite/ » & A1 & « / » & A2 & « .com »)

Enjoy !

Laisser un commentaire

Entrez vos coordonnées ci-dessous ou cliquez sur une icône pour vous connecter:

Logo WordPress.com

Vous commentez à l'aide de votre compte WordPress.com. Déconnexion / Changer )

Image Twitter

Vous commentez à l'aide de votre compte Twitter. Déconnexion / Changer )

Photo Facebook

Vous commentez à l'aide de votre compte Facebook. Déconnexion / Changer )

Photo Google+

Vous commentez à l'aide de votre compte Google+. Déconnexion / Changer )

Connexion à %s

Créez un site ou un blog sur WordPress.com

Retour en haut ↑

%d blogueurs aiment cette page :