[Sega] Megadrive 1 VA4 en Switchless

Commander le KIT Switchless depuis la Boutique 🙂
Kit Switchless

Avant de commencer on va vérifier la version de la carte mère,c’est marqué en bas de celle-ci.

Si c’est une IC BD M5 XXX VA4 vous êtes sur le bon tuto.

Sinon c’est une IC BD M5 XXX il faut aller sur ce tuto:
IC BD M5 XXX

Voici comment cela fonctionne :

Le Switchless Mod permet le Dézonage Intégral JAP/US/PAL + 50/60 Hz
en utilisant le Bouton Reset.

Changement de zone : Pressez le Bouton Reset plus d’une seconde

La Led change de couleur indiquant la Zone
(Pal : Bleu, US : Violet, Jap : Rouge)

puis relâchez le Bouton Reset pour relancer la console dans la Zone choisie

(La console redémarre en 50Hz en PAL et 60Hz en US ou JAP)

Reset Normal :
Appuyez et relâchez immédiatement le Bouton Reset pour relancer la console.

La dernière configuration choisie reste en mémoire après extinction de la console.


INSTALLATION DU MODE SWITCHLESS

Si vous avez un condensateur sur les Jumpers vous devez l’enlever !

Ici je vous présente une modification sur une Megadrive PAL mais c’est exactement la même config pour une Megadrive US ou JAP.

La seule chose qui change se situe au niveau des Jumpers,
il faut simplement couper les pistes pour enlever la configuration d’origine.

Megadrive PAL = JP2 et JP3
Megadrive US = JP2 et JP4
Megadrive JAP = JP1 et JP4

Exemple Megadrive PAL :
switch_jumpers_md1reveur

JP1 et JP2 sont reliés ensemble ce qui correspond à la langue (Pal/Us/Jap) > Pin 9
JP3 et JP4 sont reliés ensemble ce qui correspond à la fréquence (50hz/60hz) > Pin 12

Source pour plus d’information : Segakore

MD1-PAL-VA4-D4S

Diode Bicolor

Agrandir le trou pour faire passer la diode
Reliez les extrémités de la diode aux Pins 5 et 6
Reliez le centre de la diode à la Pin 14 (Gnd)

3

Enjoy !

Megadrive JAP VA4

MD JAP VA4

75 commentaires sur “[Sega] Megadrive 1 VA4 en Switchless

Ajouter un commentaire

  1. Hi friend, you dont put the 5k resistor in the video in the reset in , that VA4 megadrive 1 versión is Active High Reset needs it, what happen if you dont put it?.

    And another cuestion i see you put the PIC in the board, a lot of people put on top with glue of the bigger center chip its bad? can damage something because temperature? i think its safe really?.

    Thanks for all!.

    J'aime

  2. Sympa,mais je suis pas fan de l’IGR,clairement pour moi c’est un gadget 🙂
    Tu mets ton jeu,les 3/4 du temps tu peux laisser en US afin de forcer les jeux PAL en 60hz,et ne pas a avoir a changer pour l US et JAP.
    Si vraiment tu veux changer tu le fais avec le bouton reset mais je le faisais jamais sauf si le jeu avait une protection mais c’est rare 🙂

    J'aime

  3. ma fois on est pas obliger de l’installer le mode igr c’est un plus pas très utile je l’avoue car je ne l’utilise jamais sur la snes ;), mais ça permet pour la master system de lui ajouter un bouton pause a la manette :p et si on va plus loin ajouter un port manette usb :p

    ce qui est intéressant avec l’arduino, c’est qu’il suffit d’acheter cette carte a 2€ la brancher en usb lui envoyer le code sans avoir besoin d’un programmeur par exemple et enfin de l’installer sur la console

    J'aime

  4. Bon j’ai fait ton installation sur la V4 MD1 PAL et j’ai la diode qui reste en bleu pour le pal et s’éteint pour les autres modes ?
    Mais bien pris en compte par la console..bizarre non? .

    J'aime

  5. Et si tu inverses les pins 5 et 6 du PIC (Soit les extrémités de la diode) tu as la couleur rouge?

    Si non cela voudrait dire que tu aurais grilles la diode rouge…

    Si oui alors la par contre faut revoir ton montage et photo à m’envoyer si besoin.

    J'aime

  6. Salut Dragoncity17,

    Me voilà sur le bon tuto (pour rappel, j’avais posté sur l’autre tuto md1 switchless)
    Alors voilà les photos de la pcb en totalité :

    https://mega.nz/#!mIFFGQCQ!k9gEPi5dFUCvgJP8Y2MlnVkB-9D3szV1ZS3tGzf3tU8
    https://mega.nz/#!bFMnTCTB!cSMqkHJuk7gbAdDdsla6WegfjI2d3f5fl7rq02R6YmQ

    J’espère que c’est assez net.

    Merci de ton aide ! 🙂

    PS : J’en profite pour poser une autre question. J’ai vu trainer sur youtube des vidéos d’overclock du proc, passant de 7.67MHz à 10MHz. Le gain en fluidité (élimination des ralentissements sur sonic 2 ou thunderforce 4 par exemple) est appréciable. Qu’en penses-tu ? Est-ce une modif que tu pourrais proposer 😀 ?

    J'aime

  7. Bon ça m’a pris du temps mais j’ai fait un schéma,tu l’as dans le tuto.

    Dis moi si tout fonctionne pour toi.

    Pour l’overclock je ne fais pas car beaucoup de jeux « bug »,pas prévu pour en gros…donc voilà 😉

    J'aime

  8. Merci pour le tuto, et la réponse pour l’oc 🙂 !
    J’ai fait toutes les soudures (et verifié la continuité) et testé.
    La console est n’est plus zonée en NTSC (donc elle passe les jeux jap et us, sans distinction) mais impossible de passer en PAL et 50Hz. Comme si le bouton reset ne fonctionnait pas.
    Une idée ?

    J'aime

  9. Tu voudrais dire que le bouton reset ne fait plus rien? Ou il fonctionne comme par défaut.

    Changement de zone : Pressez le Bouton Reset plus d’une seconde

    La Led change de couleur indiquant la Zone
    (Pal : Bleu, US : Violet, Jap : Rouge)
    puis relâchez le Bouton Reset pour relancer la console dans la Zone choisie

    J'aime

  10. En fait j’ai l’impression que le bouton reset ne fait plus rien.
    J’ai vérifié les traces que j’ai coupé, j’ai bien coupé au bon endroit.
    C’est la troisième fois que je fais ce mod (MD2 et Saturn model 2 précédemment) et c’est la première fois que ça m’arrive.
    Est-ce qu’une inversion entre 2 PIC pourrait expliquer ça ? (je t’ai commandé un pic MD VA4 et un PIC Saturn sur la dernière commande)

    J'aime

  11. Saturn et MD ont a peu près le même code..sauf que VA4 le reset n’est pas au même endroit !

    https://dragoncity17.files.wordpress.com/2014/10/copie-de-saturn-hex.png?w=346&h=182

    Donc si tu as inversé…oui essaye de remettre le bon cette fois 😉

    Relie Reset (Out) sur la Pin 11 tu verras si ça change.

    Alors j’ai inventé ce schéma mais a 99% je suis sur de moi !

    En haut de Reset « In » le gros point « logiquement » doit être relié a la masse,essaye de voir si ça bip avec une masse.

    J'aime

  12. Alors, alors…
    J’ai testé avec les 2 PIC, ça ne fonctionne pas mieux.
    Interchangé le câblage du pin8 au pin 11 sur chacun des PIC -> nada
    Seule différence : l’un allume la led en violet, l’autre en rouge.

    Le gros point au dessus du Reset IN a une continuité avec la patte 72 du IC5 (5v), ou encore la patte 28 du IC3 (5v aussi). Par contre pas de continuité avec une masse comme la patte droite du JP3.

    Curieux, non ?

    J'aime

  13. Sûrement logique en fait.
    Si tu relies Reset Out (le point sur le schéma) sur le 5v le gros point vu précédemment logiquement cela doit faire un Reset.
    En fait en général la masse est utilisée pour faire un Reset mais la VA4 est différente 😅
    Donc je préfère vérifier étape par étape.

    J'aime

  14. Dans le doute, j’ai désoudé le bouton reset, enlevé la membrane, nettoyé à l’isopropanol les contacts et remonté le tout. Mais c’est pas mieux ^_^ »
    Si tu as une autre idée, je suis preneur ! 🙂

    J'aime

  15. Il fonctionnait ton bouton reset avant?

    Bon on va faire des tests,car je veux m’assurer que déjà ça fonctionne.

    Oublie le PIC pour l’instant.

    Donc dessoude les fils qui sont sur « Reset In » et « Reset Out ».

    Ensuite allume ta console.

    Avec un fil relie les 2 points : JAUNE et BLEU.

    Cela doit te faire un RESET !!!

    J'aime

  16. Alors, j’ai dessoudé tous les deux fils qui venaient du PIC et qui étaient reliés aux Reset IN et Reset OUT.
    J’ai ensuite soudé un fil sur le point jaune pour pouvoir faire le test.
    Le reset ne se fait pas sur le point bleu… mais sur celui qui est juste au dessus ! 😀

    J'aime

  17. Et…. ça ne fonctionne pas mieux ! 😦
    Pour écarter la thèse du bouton reset défectueux, j’ai récupéré celui de la MD2 que j’ai moddé l’an dernier et que je sais fonctionnel. -> le reset ne fonctionne toujours pas (le bouton fonctionne après remontage sur la MD2).

    J’ai cherché un peu et je suis tombé sur le site consolesunleashed.com.
    Dans leur mod region switchless, la piste du bouton reset est coupée juste après la resistance (cf : https://www.consolesunleashed.com/sites/all/files/images/guides/sega-mega-drive-switchless-region-mod-install-guide/mega-drive-va4-switchless-region-solder-map.jpg)
    Est-ce que cela pourrait avoir une incidence ?

    J'aime

  18. Sans aller trop loin, je pense en fait que le bouton reset ne fonctionne pas depuis le début.
    C’est une console achetée sur la baie, directement au japon, soit disant entièrement fonctionnelle. Mais j’avoue ne pas avoir vérifié le fonctionnement du reset. 😦

    S’il ne fonctionne pas, mais qu’il n’est pas en cause (test croisé avec celui de la MD2), ça signifie que ça peut venir d’une soudure ?

    J'aime

  19. Facile de tester 🙂

    Enleve les fils du PIC concernant Reset « In » et Reset « Out ».

    Relie les points « BLEU » et ORANGE » (les 2 resets).

    En fait on va refaire la liaison qui a été coupée pour vérifiez si ton bouton reset fonctionne,car si oui fonctionne pas heu..on va pas trouver ^^

    J'aime

  20. Malheureusement, ça ne fonctionne pas… 😦
    J’ai contacté le vendeur, qui bien entendu a affirmé qu’il n’était au courant.
    Une idée de ce que je pourrai vérifier pour essayer de régler ça ?

    J'aime

  21. Arf ! Donc effectivement ton bouton reset ne fonctionne pas.

    Car clairement on a juste refait la continuité…donc si t’appuies sur Reset ça devrait te faire un Reset tout simplement !

    J'aime

  22. Bon, c’est pas très grave.
    J’ai tout de même une console NTSC non zonée (donc JAP et US) mais pas de PAL 50Hz. Tous les jeux md sortis en langue française (je pense à la légende de thor, soleil ou lanstalker) sont dispo en anglais.
    Si tu as une idée de manip/soudure/vérification à effectuer pour refaire fonctionner ce bouton, je suis preneur.
    En tous cas, merci du temps que tu as passé à me dépanner, c’est très sympa et pro de ta part ! 🙂

    J'aime

  23. Alors je n’ai pas le switch de remplacement,mais clairement il te faudrait un switch on/off.

    En gros quand tu vas appuyer sur le bouton ça fera comme ton bouton reset.

    De ce style :
    https://boutique-dragoncity.myshopify.com/collections/switch-on-on-on-off/products/switch-on-on-on-off-mini-pico?variant=17168540041262

    Et tu relies directement :
    – Un côté au ROND en haut du ORANGE
    – Et l’autre sur le PIC « Pin 13 »

    Le reste comme le schéma.

    J'aime

  24. Je viens d’essayer le positionnant le switch entre le point juste au dessus du reset OUT et le point jaune : le reset se fait correctement.
    Par contre, lorsque je câble selon ce que tu me dis, ça ne fonctionne pas. J’ai vérifié 2 fois le câblage.

    J'aime

  25. Ah ça c’est pas grave, j’avais compris.
    Le soucis c’est qu’en faisant : Et tu relies directement :
    – Un côté au ROND en haut du ORANGE
    – Et l’autre sur le PIC « Pin 13 »
    Le reste comme le schéma. » -> ça ne fonctionne pas ^_^ »

    J'aime

  26. Hum..
    Tu as pas de changement de la couleur de la diode?

    Alors attend… Car t’es sur du PIC 😅

    Si tu relies le point ORANGE ou le point au dessus ça fait quoi?
    Console allumé tu relies un fil et tu regardes si la diode change de couleur.

    J'aime

  27. « Alors attend… Car t’es sur du PIC » -> Dans le doute, je teste toujours une seconde fois en basculant le cablage du PIN8 vers le PIN11 😀
    « Si tu relies le point ORANGE ou le point au dessus ça fait quoi?
    Console allumé tu relies un fil et tu regardes si la diode change de couleur.  » -> C’est à dire ? Je pars d’où ?

    J'aime

  28. En fait je veux trouver ce qui va faire réagir le PIC 🙂

    Donc on va lui mettre en Pin13 le point ORANGE et voir comment il réagit, tu relies simplement un fil de la pin13 à ce point console allumé.

    Pareil avec le point au dessus.

    Si c’est le bon point alors la diode devrait changer de couleur sans arret.

    J'aime

  29. Donc ! Le PIN8 étant connecté sur le reset OUT, le PIN13 connecté en orange ne donne rien.
    En revanche, le point qui fait enfin répondre le PIC c’est … le point situé juste à gauche de la résistance blanche, sous le « T » de OUT !! 😀

    J'aime

  30. Hum..pour être sur car ça réponds pas à ma question 🙂

    Tu soudes un fil Pin 13.
    Console allumé
    Tu me relies ce fil sur les points du reset (les gros),pas en même temps bien sur !,mais un a un..et tu me dis LEQUEL te change la couleur de la led…

    J'aime

  31. Je répète mon ancien post,lis bien tu verras ce que je te demandais 🙂

    Des 4 points du RESET (les 4 gros),lequel (logiquement il y en a 2…) mis sur la Pin 13 fait réagir la diode?

    Et tu en profiteras pour tester les 2 Pics 🙂

    J'aime

  32. Retour après une petite pause.

    J’ai tout repris, tout démonté, tout ressoudé en vérifiant plusieurs fois : toujours pareil. C’est à dire que le changement de zone fonctionne (le pic fixe correctement le 50hz pour le pal et le 60hz pour le ntcs), mais pas le reset associé, ni le Switch 50/60hz, ni même le reset tout simple. Je dois donc éteindre et redémarrer la console. Sachant que le pic garde en mémoire le dernier paramètre, ce n’est pas un soucis.

    Je pense que je vais arrêter ici, ce fonctionnement me convient pour le moment.

    Pour répondre à ta question, en coupant la trace comme tu l’indiques, j’avais 4.13v sur le reset. En coupant plus haut (après la résistance), j’obtiens du 5v.

    J'aime

  33. Oui je comprends parfaitement, je ne t’en veux absolument pas !
    Je pourrai aller plus loin si mes bases en electrotech n’étaient pas si loin.
    En tous cas, merci de ton aide et à bientôt pour la prochaine commande ! (certainement un freebios ou une fram saturn 😀 )

    Aimé par 1 personne

  34. Bonjour a tous et toutes , super tuto je pense faire ma MD1 PAL VA4 . J’ai des 16f630 et j’ai une LED tricolores mais quatre pattes comment puis je la brancher ? est ce possible ? merci pour vos réponses .

    J'aime

  35. Hello, j’ai une question. Je voudrais faire ce mod pour ma Megadrive PAL VA4 mais j’ai lu qu’il n’est pas possible avec ce modèle et ce mod de forcer les jeux PAL protégés en 60 Hz. Donc pas possible de switcher à chaud pour mettre le 60 Hz ? D’autre part, j’ai un Mega Everdrive Pro sur lequel on peut sélectionner la région, dans ce cas si je mets le switch en position US 60 Hz et que je règle la region Europe sur mon Everdrive, le jeu démarrera bien en 60 Hz ? Merci

    J'aime

  36. C’est bien cela pour les jeux PAL on ne peut pas forcer le 60Hz, donc on essaye en US, mais certains ne veulent pas !

    Aucune idée pour l’everdrive, je te dirai d’essayer et de revenir nous le dire 🙂

    J'aime

  37. Salut Dragoncity

    donc si je comprends bien ta puce switchless pour VA4 ne propose tout simplement pas de switch 50-60hz en appuyant 1/2 seconde, contrairement aux puces Megadrive classique qui auront cette fonctionnalité là ?

    J'aime

  38. La puce VA4 est destinée uniquement pour les MD VA4.
    En fait cette version de CM n’a pas le même niveau logique pour changer de région du coup on est obligé d’avoir un autre code.
    Et on ne peut pas avoir avec cette CM VA4 le PAL 60Hz.
    Mais on peut avoir le PAL 50hz US 60Hz et JAP 60Hz.

    J'aime

  39. Donc la puce VA4 peut aussi convenir aux autres cartes mères megadrive sans proposer le switch 50/60hz en appuyant une demi seconde ?
    la raison pourquoi je pose la question c’est que je souhaiterai passer commande de pls puces dont certaines seront destinées VA4 et d’autres pour MD conventionnelles, mais j’imagine que la puce pour MD4 fonctionnera pour les autres mais n’offrira pas le switch 50/60hz en appuyant 1/2 seconde sur reset ?
    merci pour tes précieux conseils

    J'aime

  40. Oui dans l’absolu ça fonctionnera, mais honnêtement ce n’est pas « top ».

    Il faudra parfois « redémarrer » la console car sinon le 60Hz ne sera pas bien pris en compte, en gros le jeu va s’accélérer mais le perso sera ralenti…

    Et oui déjà fait le teste ! 🙂

    Pour cela qu’il vaut mieux prendre le Kit Switchless qui va bien pour chaque version.

    Si non VA4, kit switchless MD, et la gros avantage de pouvoir passer les jeux PAL en 60Hz !
    Car certains ne veulent pas être passés en US/JAP, ils vont afficher un message de protection.

    Si VA4, kit switchless MD « VA4 ».
    Pas le choix sur cette version, et donc certains jeux PAL ne pourront être forcés car message de protection.

    J'aime

  41. hello, je viens de faire le mod pour moi tout est bon, j arrivais à l allumer mais la diode mais elle restait rouge, s eteingnait puis de nouveau rouge, pas de changement de couleur mais les hertz oui… je refait le reset in et out, car il y avait encore continuité, je refait les soudures… la console ne s allume plus… je vérie les régulateur de tension, ils sortent tout les 2 du 5v… la je comprends plus… j essaie en dessoudant tout?

    J'aime

  42. Hello,

    Oui essaye de voir en dessoudant fil par fil voir ce qui bloque.

    Tu peux dans un premier temps tester en dessoudant la Pin 1 pour le 5V, et voir si déjà elle fonctionne.

    Vérifie bien et si besoin partage des photos :

    —————
    Allez sur https://www.zupimages.net
    Cliquez sur Parcourir et choisir votre image.
    Copier l’URL à droite de « Lien direct de votre image » >> TRÈS IMPORTANT !!!
    Coller l’url directement en commentaire ! 🙂
    —————

    J'aime

  43. yop, j ai enlevé la puce histoire de voir sans… la console est en 60 htz, a mon avis, j ai des jp qui se touchent ou des soucis à ce niveau la…

    J'aime

  44. Non c’est normal, comme on a coupé les jumpers elle est maintenant en 60Hz.

    Essaye maintenant de brancher au fur et a mesure jusqu’à trouver ce qui fait « sauter » la led ou ne plus la faire fonctionner.

    J'aime

  45. j ai testé la continuité des pistes c est bon, malgré que mon cutter à glisser 🙂 elle avait fonctionner malgré cela avant que je ne coupe la piste reset derriere… il y a moyen de voir si les 5v arrive à la puce? car sans puce ca fonctionne, je me demande si la puce est pas morte…

    J'aime

  46. Sans puce cela fonctionne dans le sens où tu peux jouer?

    Donc relie uniquement la Pin 1 (5V) et 14 (0V). Tu pourras mesurer ensuite si tu as bien 5v sur la puce.

    Puis ensuite relie fil par fil en testant a chaque fois voir lequel fait que ça fonctionne plus.

    J'aime

  47. Je dois mesurer entre la pin 1 et 14 le voltage? Car rien qu en soudant ces 2 la ça ne s allume pas, tandis que sans la puce ça démarre…

    J'aime

  48. Comme sur la photo, seulement le pin 1 et 14 sont soudés… Je dois faire quelle mesure alors? Je peux lancer avec juste la 1 a 5v sans la 14 la terre?

    J'aime

  49. Oui bien sur ça ne fera rien en fait. Mais si l’un des 2 empêchent de booter alors on aura identifier le coupable.

    Enlève également le fil violet sur le 0V.

    J'aime

  50. petite question, j ai tout restesté, la console fonctionne en 60 htz, mais la led s allume pas… je pense que c est le point bleu clair du reset sur ton schéma qui merde chez moi, y aurait il un point alternatif plus loin pour ce point? car j ai fait une boucherie à l arriere pour couper la ligne ;(((

    merci!

    J'aime

  51. Si la led ne s’allume pas c’est car le PIC n’est pas alimentée (5V et 0V), c’est lui qui alimente ensuite la led à chaque ANDODE, et la pate du milieu la masse la CATHODE.

    Pour le point bleu c’est une piste… donc difficile comme ça avec des photos ça m’aiderait plus 🙂

    J'aime

  52. je crois avoir trouvé, je t avais pris 2 puces et j ai mis la deuxième, et la led s allume! donc je pense que la première puce est morte… de meme, j ai refait un pont entre le pin orange et le bleu ciel pour relier les 2 reset, j ai tester la continuité ca refonctionne, mais pas le bouton reset…

    en résumé j ai une puce morte combinée à un bouton reset qui ne fonctionne plus (et pourtant il allait avant, je l avais tester…)

    donc je vais voir pour trouver un switch et passer directement par la… tu en vends ou tu saurais ou je pourrais en trouver un? merci!

    J'aime

  53. C’est normal pour ton bouton reset, tu as coupé la piste donc il ne fonctionne plus.

    C’est pour ensuite que la puce gère justement le bouton reset que l’on fait cela.

    Donc si tu relies ensuite le bouton reset à ta puce ça fonctionnera, mais il faut que la puce soit bonne effectivement si maintenant elle est HS tu vas être bloqué.

    Le schéma de câblage est différent sur une « non va4 » voir :

    [Sega] Megadrive 1 en Switchless

    Mais il faut utiliser une puce VA4 sur une VA4 sinon « bugs ».

    Pour tes tests tu peux simplement relier Pin 1 et 14 pour l’alimenter et Pins 11 et 13 pour le reset avec cette nouvelle puce.

    Logiquement ton bouton reset refonctionnera si tu fais un appuie court.

    J'aime

  54. hello, j ai testé le reset, je pense que j ai surement coupé ou il ne fallait pas, il ne va plus… pas grave je mettrai un switch 😉

    par contre j ai trouvé une photo ou il y a un point alternatif pour celui qui ne le sent pas trop de dénuder la piste, je te met la photo si cela t interesse 😉 le cercle rouge remplace la soudure du cable blanc, c est comme pour les ps1, il faut un peu gratter le cercle pour souder 😉

    J'aime

  55. Bonjour j’ai un petit souci lorsque j’appuie sur reset la led qui est rouge s’eteint et se rallume en rouge. d’apres une cartouche megadrive je serai en ntsc us, petite question apres avoir teste je ne trouve pas de probleme particulier sauf j’aimerai savoir si il est normal d’avoir un contact entre jp3 et jp4 les pastille de bas c’est a dire sur le shema la pastille verte et celle d’as cote ?

    J'aime

  56. En fait non tout vas bien j’ai remis une vis ou deux sur le blindage et la soudure de ma led avait sauté.

    J'aime

Votre commentaire

Entrez vos coordonnées ci-dessous ou cliquez sur une icône pour vous connecter:

Logo WordPress.com

Vous commentez à l’aide de votre compte WordPress.com. Déconnexion /  Changer )

Photo Google

Vous commentez à l’aide de votre compte Google. Déconnexion /  Changer )

Image Twitter

Vous commentez à l’aide de votre compte Twitter. Déconnexion /  Changer )

Photo Facebook

Vous commentez à l’aide de votre compte Facebook. Déconnexion /  Changer )

Connexion à %s

Créez un site ou un blog sur WordPress.com

Retour en haut ↑

%d blogueurs aiment cette page :